InterVLAN

มา Config Inter-VLAN Routing บน Switch Layer 3 และ Router Cisco กันครับ 

Inter-VLAN Routing คือการทำให้ host ( PC,Notebook,Server) ที่อยู่ต่าง VLAN กัน ติดต่อกันได้ โดยต้องมีอุปกรณ์ที่อยู่ใน Layer 3 มาช่วย ตัวอย่างอุปกรณ์ Layer 3 ที่ทำ InterVLAN ได้เช่น Router , Switch Layer 3, Firewall เป็นต้น ในที่นี้จะเสนอวิธีการทำ Inter-VLAN บน Switch Layer 3 ของ Cisco โดยการทำ Inter-VLAN Routing บน Switch Layer 3 ของ Cisco จะมี 3 ขึ้นตอน ดังนี้

1) Set Trunk Port ก่อน โดยปกติค่า encapsulation ของ Trunk Port นั้นจะอิงตามมาตรฐานของ IEEE 802.1Q ตัวอย่างการ Config trunk ที่ interface f0/1 เป็นดังนี้

SW-L3(config)#interface f0/1
SW-L3(config-if)#switchport trunk encapsulation dot1q
SW-L3(config-if)#switchport mode trunk

2) Config VLAN ให้ทำการสร้างเลข VLAN และกำหนดชื่อ VLAN ดังตัวอย่าง เป็นการ สร้าง VLAN 20 และ VLAN 30 ดังนี้

SW-L3(config)#vlan 20
SW-L3(config-vlan)#name Admin
SW-L3(config-vlan)#vlan 30
SW-L3(config-vlan)#name User

3) Config SVI ( Switch Virtual Interface ) ให้ทำการสร้าง Interface VLAN และใส่ IP Address ที่จะเป็น Gateway ให้กับhost ( PC,Notebook,Server) ในแต่ละ VLAN ดังตัวอย่าง

SW-L3(config)#interface vlan 20
SW-L3(config-if)#ip address 192.168.1.254 255.255.255.0
SW-L3(config-if)#bandwidth 2048
SW-L3(config-if)#description link-to-vlan-20

SW-L3(config-if)#interface vlan 30
SW-L3(config-if)#ip address 192.168.2.254 255.255.255.0
SW-L3(config-if)#bandwidth 20480
SW-L3(config-if)#description link-to-vlan-30

และให้ตรวจสอบว่ามีการ Config command ip routing ไว้หรือยัง เพื่อให้ Switch Layer 3 ของ CISCO ทำ routing ได้ถูกต้องด้วย
SW-L3(config)#ip routing

ถ้า config ถูกต้องเมื่อทำการ show ip route Switch Layer 3 ต้องรู้จัก 2 Network ดังด้านล่างนะครับ

SW-L3#show ip route
Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, Vlan20
C 192.168.2.0/24 is directly connected, Vlan30

หลังจากนั้นให้ทำการทดสอบการติดต่อระหว่าง PC ที่อยู่ต่าง VLAN กันนะครับ

 

ต่อไปเป็นตัวอย่างการ Set Config Inter-VLAN Routing บน Router Cisco ซึ่งต้องมีการแบ่ง Sub Interface ให้แต่ละ VLAN เช่น VLAN 20 ให้อยู่ sub interface ที่ 1 และ VLAN 30 ให้อยู่ sub interface ที่ 2 ดังตัวอย่างด้านล่างนะครับ
1. ให้ทำการเปิด Interface หลักก่อน เช่น ทำการเปิด Interface G0/0 ด้วยการ no shutdown
Router(config)#interface g0/0
Router(config-if)#no shutdown

2. ทำการสร้าง Sub Interface ใส่ IP Address และค่า Encapsulation เป็น IEEE 802.1Q และระบุเลข VLAN
Router(config)#interface gigabitEthernet 0/0.1
Router(config-subif)#encapsulation dot1Q 20 ( VLAN 20 )
Router(config-subif)#ip address 192.168.1.254 255.255.255.0
Router(config-subif)#description link-to-Vlan20

Router(config-subif)#interface gigabitEthernet 0/0.2
Router(config-subif)#encapsulation dot1Q 30 ( VLAN 30 )
Router(config-subif)#ip address 192.168.2.254 255.255.255.0
Router(config-subif)#description link-to-Vlan30

Router#show ip route
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet0/0.1
L 192.168.1.254/32 is directly connected, GigabitEthernet0/0.1
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, GigabitEthernet0/0.2
L 192.168.2.254/32 is directly connected, GigabitEthernet0/0.2
192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks

หลังจากนั้นให้ทำการทดสอบการติดต่อระหว่าง PC ที่อยู่ต่าง VLAN กันนะครับ โดยการ ping test

ดูตัวอย่างวีดีโอการ Config InterVLAN บน Router CISCO ได้ตามด้านล่างนะครับ

 

หวังว่าบทความนี้คงจะเป็นประโยชน์ ไม่มากก็น้อยนะครับ

 

More About us

"Jodoi The Best IT in Thailand" ศูนย์ฝึกอบรม Network และ IT เป็นบริษัทที่เป็นศูนย์อบรม และจัดจำหน่ายคอมพิวเตอร์ ระบบ Network และไอทีครบวงจร อันดับ 1 ของเมืองไทย

Jodoi Training Center

Facebook

นายเกรียงศักดิ์ นามโคตร (อาจารย์ดอย) ผู้ก่อตั้งบริษัท โจดอย ไอทีแอนด์เซอร์วิส จำกัด เจ้าของแบนด์โจดอย (JODOI) และเจ้าของสโลแกน " โจดอยทำได้ คุณก็ต้องทำได้ " รูัจัก อาจารย์ดอยมากขึ้น more

 

Contact Us

Mr. Kriangsak namkot
Mobile:081-9165773
E-mail:jodoi@jodoi.com