Basic config CISCO

มาหัด Configuration Router CISCO ด้วย Command Line กันครับ 

ในการที่เราจะเข้าไป Configuration Router Cisco ได้นั้น ต้องมีการต่อสาย Console ระหว่าง Router CISCO กับ PC หรือ Notebook ก่อน ตามรูปด้านล่างนะครับ

และให้เข้าใช้งานผ่านโปรแกรม terminal เช่น hyper terminal หรือ Putty เป็นต้น และ Set Speed Console เป็น 9600 ดังรูปภาพด้านล่างเป็นตัวอย่างการตั้งค่าของโปรแกรม Putty

เมื่อเข้าได้ ถ้าเป็น Router ตัวใหม่จะปรากฎข้อความตามด้านล่าง

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no ( พิมพ์ no เพื่อจะ Configuration ทั้งหมดเอง )
Press RETURN to get started!
Router>
Router> (เครื่องหมาย > หมายถึง อยู่ใน user mode )
Router>enable ( เมื่อต้องการเปลี่ยนจาก user mode เป็น privileged mode )
Router# ( เครื่องหมาย # หมายถึง privileged mode, enable mode หรือ Admin mode )
Router#show ? ( สามารถใช้ Help คือเครื่องหมาย ? เพื่อตรวจสอบ Command Line ที่สามารถใช้ได้ว่ามีอะไรบ้าง )
--
--
flash: display information about flash: file system
running-config Current operating configuration
startup-config Contents of startup configuration
version System hardware and software status
--
--

Router#show version ( เป็นการตรวจสอบ Spec Router และดู version IOS )
Router#show flash: ( เป็นการดูขนาดของ IOS และพื้นที่ของ Flash )
Router#show startup-config ( ดู Configuration ตอนเริ่มต้นที่ Save ไว้ )
startup-config is not present ( แสดงว่ายังไม่ได้มีการ Save Config ไว้ )

Router#show running-config (ดู Configuration ปัจจุบัน )

Router#copy running-config startup-config ( การ Save Configuration )
Destination filename [startup-config]?
Building configuration...
[OK]

ต่อไปเป็นขั้นตอนการ Configuration Router CISCO

Router#config terminal ( การเข้าสู่ Mode Configuration )
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ( แสดงให้รู้ว่าอยู่ใน configuration mode )

1) การ Configuration hostname ( ควรตั้งตามสถานที่ติดตั้ง Router เช่น ชื่อจังหวัด ชื่ออำเภอ ชื่อตึก เป็นต้น )
รูปแบบ คือ hostname ตามด้วยตัวอักษร เช่น
Router(config)#hostname Jodoi-Router ( ตั้งชื่อ Hostname เป็น Jodoi-Router )
Jodoi-Router(config)# (จะเห็นว่า มีการเปลี่ยนจากเดิม hostname Router เป็น hostname Jodoi-Router )

2) การ Configuration line console ( ควรตั้ง Password ไว้ เพื่อป้องกันบุคคลภายนอกเข้ามาตรวจสอบข้อมูลของ Router )
Jodoi-Router(config)#line console 0 ( console 0 หมายถึง มี port console เพียง port เดียว คือ port 0 )
Jodoi-Router(config-line)#password cisco ( ตั้ง password เป็นคำว่า cisco )
Jodoi-Router(config-line)#login ( เป็นการบังคับให้ตรวจสอบ password )

3) การ Configuration enable password ( ตั้ง Password ในการเปลี่ยนจาก user mode เป็น privileged mode เพื่อความปลอดภัยมากขึ้น )
Jodoi-Router(config)#enable password 1234 ( ตั้ง password เป็นคำว่า 1234 )

4) การ Configuration enable secret ( เป็นการตั้ง Password ในการเปลี่ยนจาก user mode เป็น privileged mode เช่นเดียวกับ enable password แต่จะมีการเข้ารหัสไว้ เมื่อใช้ command show running-config จะไม่เห็น)
Jodoi-Router(config)#enable secret jodoi ( ตั้ง password เป็นคำว่า jodoi )

ในการทำงานจริงควรเลือกใช้อย่างใดอย่างหนึ่งระหว่าง enable password และ enable secret แต่ถ้ามีการ Configuration ไว้ทั้ง 2 แบบ Router CISCO จะเลือก password ของ enable secret ในการเปลี่ยนเป็น privileged mode

Jodoi-Router(config)#no enable secret (เป็นตัวอย่างการลบ Configuration ออก โดยใช้ no ข้างหน้า )

5) การ Configuration line vty ( เป็นการเปิด Service ให้ Remote ได้ โดยเฉพาะการ Telnet )

Jodoi-Router(config)#line vty 0 4 ( 0 4 หมายถึง เปิดไว้ 5 line หรือ 5 sessions หรือคนที่ 1 ถึงคนที่ 5 )
Jodoi-Router(config-line)#password cisco ( ตั้ง password เป็นคำว่า jcisco )
Jodoi-Router(config-line)#login ( เป็นการบังคับให้ตรวจสอบ password )

6) การ Configuration Banner ( ข้อความต้อนรับหรือคำเตือนก่อนเข้า Router )
Jodoi-Router(config)#banner motd 2 ( banner motd ตามด้วยตัวอักษรอะไรก็ได้ เช่น ใช้เลข 2 เริ่มต้น ก็ต้องจบตัวเลข 2 )

Enter TEXT message. End with the character '2'.

#########################################################
#########################################################
#### Welcome to Jodoi-Router ###
#### Please Do not Change Password ###
#########################################################
#########################################################2

จบประโยคด้วยตัวอักษรที่เริ่มต้น คือเลข 2

7) การ Configuration IP Address ที่ Interface

Jodoi-Router(config)#interface f0/0
Jodoi-Router(config-if)#ip address 192.168.1.254 255.255.255.0 ( IP Address และ Subnet Mask )
Jodoi-Router(config-if)#description link-to-lan-A (ใส่ หมายเหตุหรือคำอธิบายกำกับ )
Jodoi-Router(config-if)#no shutdown ( เป็นการเปิดให้ Port f0/0 ทำงานได้ )

Configuration IP ที่ interface f0/1 ทำเช่นเดียวกันกับ interface f0/0 แต่ IP Address ต้องเป็นคนละ Subnet

Jodoi-Router(config)#interface f0/1
Jodoi-Router(config-if)#ip address 192.168.2.254 255.255.255.0
Jodoi-Router(config-if)#description link-to-lan-B
Jodoi-Router(config-if)#no shutdown

Jodoi-Router#show ip route ( เป็นการตรวจสอบ Routing Table ของ Router
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/1

จะเห็นว่า Router CISCO จะรู้จักทั้ง 2 Subnet

ดูตัวอย่างการ Config IP ที่ Router ได้จากวีดีโอด้านล่างนะครับ

 

8) การเพิ่ม Username ใน Router CISCO หรือ User local สามารถทำได้ดังนี้ การเข้าสู่ Mode Configuration
Jodoi-Router(config)#username jodoi password cisco ( Add Username "jodoi" โดยมี password เป็น "cisco" )
Jodoi-Router(config)#username admin password admin12 ( Add Username "admin" โดยมี password เป็น "admin12" )

สามารถตรวจสอบ Username ที่มีอยู่ใน Router ได้โดยการ show running-config

Jodoi-Router#show running-config
!
username admin password 0 admin12
username jodoi password 0 cisco
!
!
เราสามารถนำ Username local เหล่านี้ไปใช้ในหลายเรื่อง เช่นใช้ในการ Telnet ,Secure Shell , การ Connect WAN แบบ PPP PAP ,PPP CHAP เป็นต้น

ตัวอย่างการทำให้การ Telnet เข้า Router CISCO ต้องมีการใส่ Username และ Password ด้วยดังนี้

Jodoi-Router(config)#line vty 0 4
Jodoi-Router(config-line)#login local ( เพิ่มคำว่า local ต่อท้าย login )

เท่านี้ก็จะทำให้เมื่อ User telnet เข้า Router CISCO ต้องใส่ Username ที่มีอยู่ใน Router CISCO ก่อนเท่านั้น ทำให้มีความปลอดภัยมากขึ้น

ตามภาพด้านล่างนะครับ

9) การ Backup Config บน Router CISCO ทำได้โดยการ Backup ไว้ที่ TFTP Server โดยจะต้องมีการติดตั้งโปรแกรม TFTP ไว้บน PC หรือบน Server ก่อน
หลังจากนั้นให้ใช้ command copy ดังนี้
Jodoi-Router#copy running-config tftp:
Address or name of remote host []? 192.168.1.50 ( ให้ใส่ IP ของ TFTP Server )
Destination filename [Jodoi-Router-confg]? Backup_config_01012014 ( ให้ตั้งชื่อ file โดยควรระบุวันที่ที่ทำการ Backup file ด้วย )
!!
623 bytes copied in 1.028 secs (606 bytes/sec)

Jodoi-Router#

ดูตัวอย่างการ Backup Config ได้จากวีดีโอด้านล่างนะครับ

 

10) การ ดึง Config จาก TFTP Server กลับมาที่ Router CISCO ทำได้ดังนี้
Jodoi-Router#copy tftp: running-config
Address or name of remote host []? 192.168.1.50 ( ให้ใส่ IP ของ TFTP Server )
Source filename []?Backup_config_01012014 ( ใส่ ชือ file ที่ทำการ Backup ไว้ ให้ถูกต้อง )
Destination filename [running-config]?
Accessing tftp://192.168.1.50/r1720b-confg...
Loading r1720b-confg from 192.168.1.50 (via FastEthernet0): !
[OK - 680 bytes]

680 bytes copied in 0.908 secs (749 bytes/sec)
Jodoi-Router#
ข้อควรระวังทั้งในส่วนของการ Backup Config บน Router CISCO และการดึง Config จาก TFTP Server กลับมาที่ Router CISCO นั้น ตัว TFTP Server และ Router CISCO ต้องติดต่อกันได้ก่อนและไม่ติด Firewall หรือ Anti-Virus ต่างๆ โดยการทดสอบ ping ก่อนที่จะดำเนินการ ตัวอย่างโปรแกรมCisco TFTP Server ดังรูปด้านล่างนะครับ

 11) การ Recovery Password Cisco Router

จะมีอยู่หลายครั้งที่เราลืม Password เข้า Router CISCO ทั้งในส่วนของ Console หรือ enable Mode หรือไม่ได้ลืมแต่เจ้าหน้าที่ที่ดูแล Router คนเก่าไม่ได้บอกไว้ ทำให้มีความจำเป็นต้องทำการ Recovery Password ขั้นตอนการ การ Recovery Password Cisco Router นั้นดูได้ตาม link ครับ http://www.jodoi.com/book/Password_Recovery_on_Cisco_Router.pdf

หรือ ดูจากวีดีโอใน youtube ด้านล่าง ครับ

12)  การ Recovery Password Switch CISCO

จะมีอยู่หลายครั้งที่เราลืม Password เข้า Switch CISCO ทั้งในส่วนของ Console หรือ enable Mode หรือไม่ได้ลืมแต่เจ้าหน้าที่ที่ดูแล Switch CISCO คนเก่าไม่ได้บอกไว้ ทำให้มีความจำเป็นต้องทำการ Recovery Password ขั้นตอนการ การ Recovery Password Cisco Switch นั้นดูได้ตาม link ครับ

http://www.jodoi.com/book/Password%20Recovery%20on%20Cisco%20%20Switch%20L3.pdf

หรือดูจากวีดีโอใน youtube ด้านล่างครับ

 

หวังว่าบทความนี้คงจะเป็นประโยชน์ไม่มากก็น้อยนะครับ ขอบคุณครับ

 

เรียบเรียงโดย อาจารย์เกรียงศักดิ์ นามโคตร ( อาจารย์ดอย ) Mr.Jodoi

More About us

"Jodoi The Best IT in Thailand" ศูนย์ฝึกอบรม Network และ IT เป็นบริษัทที่เป็นศูนย์อบรม และจัดจำหน่ายคอมพิวเตอร์ ระบบ Network และไอทีครบวงจร อันดับ 1 ของเมืองไทย

Jodoi Training Center

Facebook

นายเกรียงศักดิ์ นามโคตร (อาจารย์ดอย) ผู้ก่อตั้งบริษัท โจดอย ไอทีแอนด์เซอร์วิส จำกัด เจ้าของแบนด์โจดอย (JODOI) และเจ้าของสโลแกน " โจดอยทำได้ คุณก็ต้องทำได้ " รูัจัก อาจารย์ดอยมากขึ้น more

 

Contact Us

Mr. Kriangsak namkot
Mobile:081-9165773
E-mail:jodoi@jodoi.com