You Can If You Think You Can >
Mr.Jodoi say

" โจดอยทำได้คุณก็ต้องทำได้ "

นายเกรียงศักดิ์ นามโคตร (อาจารย์ดอย)

ผู้ก่อตั้ง บริษัทโจดอย ไอทีแอนด์เซอร์วิส จำกัด ปัจจุบันดำรงตำแหน่งกรรมการผู้จัดการบริษัทโจดอย ไอทีแอนด์เซอร์วิส จำกัดและเป็นวิทยากรบรรยายพิเศษให้กับหน่วยงานทั้งภาครัฐและเอกชน

Certifications :
- CCNA (Cisco Certify Nework Associate)
- CCNA Security (Cisco Certified Network Associate Security)
- CCDA (Cisco Certified Design Associate)
- Cisco Express Foundation Design Specialist
- CCNP (Cisco Certified Network Professional)
- CCDP (Cisco Certified Design Professional)
- SBCSEN , SBCSAM , SMBAM , SMBEN , CQS-SMBE from Cisco SMB University
- CompTIA Linux+
- CompTIA Security+
- Pearson VUE Certified Administrator

More

--------------------------------------------------------------------

Basic Network Command by Mr.Jodoi

มาเรียนรู้การใช้ Network Command เบื้องต้นกันนะครับ ขอแนะนำ command ping และ command traceroute จากวีดีโอที่อาจารย์เกรียงศักดิ์ นามโคตร (อาจารย์ดอย) ทำไว้ใน youtube ครับ


IP Address version 4 ตอนที่ 1 by Jodoi

มาเรียนรู้การคำนวณ IP Address version 4 ด้วยเทคนิคการใช้ตารางมหัศจรรย์ซึ่งทำให้ศิษย์นำไปใช้ในการทำงานและการสอบ Cert.IT ได้อย่างดีเยี่ยม

Basic Linux Command ตอนที่ 1 (ls,cat,vi)by Jodoi

มาเรียนรู้การใช้ Linux Command เบื้องต้นกันครับ เริ่มต้นด้วย command ls , cat และ vi ซึ่งปัจจุบันมีความจำเป็นต้องเรียนรู่อย่างยิ่งเพราะหลายๆองค์กรมีการใช้ Linux Server กันมากขึ้น

 

และยังมีวีดีโอดีๆอีกมากมายรับชมได้ใน แชลแนล Mr.Jodoi ตามด้านล่างนะครับ

https://www.youtube.com/user/MrJodoi

 




Config PPP PAP&CHAP

มา Config PPP PAP และ PPP CHAP บน CISCO Router กันครับ

ก่อนที่จะ Config PPP PAP และ CHAP บน CISCO Router เรามาทบทวนการ Config WAN Serial แบบ HDLC กันก่อนนะครับ รูปแบบ Config เป็นดังนี้

R1(config)#interface s0/0/0
R1(config-if)#ip address 10.10.10.5 255.255.255.252
R1(config-if)#encapsulation hdlc ( เป็นค่า Default ของ Serial CISCO )
R1(config-if)#clock rate 128000 ( เฉพาะฝั่ง DCE )
R1(config-if)#bandwidth 2048 ( ค่า Default BW 1544 Kbit ( T1) )
R1(config-if)#description link-to-R1
R1(config-if)#no shutdown

R2(config)#interface s0/0/0
R2(config-if)#ip address 10.10.10.6 255.255.255.252
R2(config-if)#no shutdown
R1#show interfaces s0/0/0
Serial0/0/0 is up, line protocol is up (connected)
R1#show ip route
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.4/30 is directly connected, Serial0/0/0
L 10.10.10.5/32 is directly connected, Serial0/0/0

R1#ping 10.10.10.6 ( R1 ต้องสามารถ ping ไปหา IP ของ R2 ได้ )
!!!!!

สามารถดูตัวอย่างการ Config HDLC ได้ตามวีดีโอด้านล่างนะครับ

 

PPP ( Point-to-Point Protocol ) สามารถใช้ในการขนส่ง packet ได้หลากหลาย protocol เช่น TCP/IP ,Novell IPX ,Apple Talk เป็นต้น และ PPP ยังสามารถใช้ได้ในการสื่อสารแบบ synchronous และ asynchronous ด้วย
PPP มีวิธีการพิสูจน์ผู้ใช้อีก 2 วิธี คือ PAP (Password Authentication Protocol) และ CHAP (Challenge-Hand-shake Authentication Protocol)
คุณสมบัติของ PAP (Password Authentication Protocol) มีดังนี้
- Two-way Handshake ( เป็นการ Authentication แบบ 2 ทางคือส่ง Username และ password ไปตรวจสอบ ถ้าถูกต้องก็สามารถเชื่อมต่อได้ ถ้าผิดก็จะโดนปฏิเสธการเชื่อมต่อ )
- Password send in plaintext ( ไม่มีการเข้ารหัส Username และ Password ในระหว่างการขอเชื่อมต่อ)

คุณสมบัติของ CHAP (Challenge-Hand-shake Authentication Protocol)
- Three-way Handshake ( เป็นการ Authentication แบบ 3 ทางคือ 1)ก่อนที่จะมีการเชื่อมต่อ จะมีการส่งค่า Challenge ให้ผู้ที่จะเชื่อมต่อ 2)มีการนำ Username และ password มาเข้ารหัสก่อนที่จะทำการเชื่อมต่อ 3) ถ้าถูกต้องก็สามารถเชื่อมต่อได้ ถ้าผิดก็จะโดนปฏิเสธการเชื่อมต่อ )
- Hash values, not actual passwords, are sent across the link. ( มีการเข้ารหัส Username และ Password ด้วยวิธีการ Hashing )

ตัวอย่างการ Config PPP PAP และ PPP CHAP บน Interface Serial CISCO Router

###### การ Config PPP PAP ########
1) สร้าง Username และ Password ( User Local ) ทำที่ configuration mode
R1(config)#username Admin password 1234
R2(config)#username abcd password cisco

2) เปลี่ยนค่า Encapsulation ที่ Interface Serial เป็น PPP PAP ทำที่ configuration interface mode
R1(config)#interface s0/0/0
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication pap
R1(config-if)#ppp pap sent-username abcd password cisco

R2(config)#interface s0/0/0
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication pap
R2(config-if)#ppp pap sent-username Admin password 1234

ตรวจสอบผล
R1#show interfaces s0/0/0
Serial0/0/0 is up, line protocol is up (connected) ------> ( line protocol ต้อง Up )

###### การ Config PPP CHAP ########
1) สร้าง Hostname
R1(config)#hostname bangkok
R2(config)#hostname phuket

2) สร้าง Username และ Password ( User Local )
โดยนำ Hostname ของ Router ฝั่งตรงข้ามมาสร้างเป็น Username และใช้ Password ร่วมกัน
bangkok(config)#username phuket password cisco
phuket(config)#username bangkok password cisco

3) เปลี่ยนค่า Encapsulation ที่ Interface Serial เป็น PPP CHAP
bangkok(config)#interface s0/0/0
bangkok(config-if)#encapsulation ppp
bangkok(config-if)#ppp authentication chap

phuket(config)#interface s0/0/0
phuket(config-if)#encapsulation ppp
phuket(config-if)#ppp authentication chap

bangkok#show interfaces s0/0/0
Serial0/0/0 is up, line protocol is up (connected

ทดสอบทำ Lab http://www.jodoi.org/article/Jodoi_Lab_ppp.pkt

ถ้าทำถูกต้อง Router R1 ต้องสามารถ ping 10.10.10.6 ได้ตามผลด้านล่าง

R1#ping 10.10.10.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/11/15 ms

R1#

ดูตัวอย่างการ Config PPP CHAP ได้ตามวีดีโอด้านล่างนะครับ

ในกรณีที่พบปัญหา line protocol is down สามารถใช้ command # debug ppp authentication เพื่อตรวจสอบปัญหาได้ เช่น

bkk#debug ppp authentication

bkk#no debug all ( หยุดการ debug หรือจะใช้ #undebug all ก็ได้ )
All possible debugging has been turned off

การวิเคราะห์ปัญหา ในส่วนของ WAN บน Router CISCO
1.ตรวจสอบในส่วนของ Layer 1 ( Physical Layer ) ต้อง Up ก่อน ด้วย Command # show ip interface brief และ #show interfaces s0/0/0
bangkok#show ip interface brief
Interface IP-Address OK? Method Status Protocol

GigabitEthernet0/0 unassigned YES unset administratively down down

Serial0/0/0 unassigned YES unset administratively down down

Serial0/0/1 unassigned YES unset administratively down down

bangkok#show interfaces s0/0/0
Serial0/0/0 is administratively down, line protocol is down (disabled)

จากการตรวจสอบพบว่า Serial0/0/0 is administratively down หมายความว่า Interface Serial0/0/0 ยังคงถูก Shut down อยู่

หลังจากทำการ no shutdown Interface Serial0/0/0 แล้วตรวจสอบใหม่

bangkok#show interfaces s0/0/0
Serial0/0/0 is down, line protocol is down (disabled)

พบว่า Serial0/0/0 is down ต้องทำการตรวจสอบเรื่องสาย Serial และตรวจสอบ Router ฝั่งตรงข้ามว่าทำการ no shutdown Interface Serial ที่ต่อกับ Router เราหรือยัง ตรวจสอบที่เกี่ยวกับ Layer 1 ทั้งหมด

หลังจากตรวจสอบแล้ว ถ้าได้ผลดังนี้
bangkok#show interfaces s0/0/0
Serial0/0/0 is up, line protocol is down (disabled)

ให้ตรวจสอบในส่วนของ Layer 2 ต่อ
2. การตรวจสอบ Layer 2 ได้แก่ การตรวจค่า Config Encapsulation ของ Router ทั้ง 2 ฝั่งต้องตรงกัน ถ้ามีการ Set แบบ PPP ตรวจสอบในเรื่องของ Username และ Password ด้วยว่าตรงตามเงื่อนไข PAP และ CHAP หรือไม่ รวมถึงค่า Clock rate ด้วย ในกรณีที่ Router เป็น DCE ต้อง Set ให้ถูกต้อง ( โดยปกติ Router จะเป็น DTEเสมอ ยกเว้นในการทำ Lab ในห้องเรียนหรือใน program simulation เช่น Cisco Packet Tracer ) ถ้าถูกต้อง ต้องจะได้ผลดังนี้

bangkok#show interfaces s0/0/0
Serial0/0/0 is up, line protocol is up (connected)

หลังจากนั้นตรวจสอบโดยการ ping ไปที่ IP ของ Router ฝั่งตรงข้าม

ข้อแนะนำเพิ่มเติม ในการแก้ไข Config ทุกครั้งควรตรวจสอบ Config เดิม หรือ Backup Config เดิมไว้ก่อนนะครับ

####### การ Config MLPPP ( Multilink PPP ) #################

MLPPP เป็นการรวม WAN Serial ตั้งแต่ 2 Link รวมเป็น Link เดียวกัน โดยมีรูปแบบการ Config ดังนี้ครับ
R1(config)#interface multilink 1
R1(config-if)#ip address 10.10.10.101 255.255.255.252
R1(config-if)#ppp multilink group 1

R1(config)#interface s0/0
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown

R1(config)#interface s0/1
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#no shutdown

R2(config)#interface multilink 1
R2(config-if)#ip address 10.10.10.102 255.255.255.252
R2(config-if)#ppp multilink group 1

R2(config)#interface s0/0
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink group 1
R2(config-if)#no shutdown

R2(config)#interface s2/0
R2(config-if)#encapsulation ppp
R2(config-if)#ppp multilink group 1
R2(config-if)#no shutdown

ในส่วนของ interface ที่อยู่ภายใน multilink group 1 นั้นจะทำการ set เป็น ppp pap หรือ ppp chap ก็ได้ครับ ตรวจสอบผลการ Config ได้ดังนี้

R1#show interfaces multilink 1
Multilink1 is up, line protocol is up

R1#show ip interface brief
Interface IP-Address OK?Method Status Protocol
FastEthernet0/0 192.168.1.254 YES manual up up
Serial0/0 unassigned YES manual up up
Serial0/1 unassigned YES unset up up
Multilink1 10.10.10.101 YES manual up up

ทดลอง ping test ไปที่ปลายทางจะได้ผลดังด้านล่าง

R1#ping 10.10.10.102
!!!!!

ทดสอบ shutdown interface s0/1 ของ R1 ดู จะเห็นว่า multilink 1ยังคง Up อยู่ และ ยังคงใช้งานได้ดังเดิม

R1(config)#interface s0/1
R1(config-if)#shutdown

R1#ping 10.10.10.102
!!!!!

หวังว่าบทความนี้คงจะเป็นประโยชน์ ไม่มากก็น้อยนะครับ

 

--------------------------------------------------------------------------------------------------------

บทความ Network

บทความ Linux

บทความ Certificate