Routing Protocol

มา Confg Routing บน Router CISCO กันครับ 

Routing Protocol คือ Protocol ที่ใช้ในการแลกเปลี่ยน routing information ระหว่างอุปกรณ์เครือข่ายต่างๆที่ทำงานในระดับ Network Layer (Layer 3) ได้แก่ Router , Switch Layer 3 , Firewall ,Linux Server รวมถึง OS ต่างๆ เป็นต้น เพื่อให้อุปกรณ์เหล่านี้สามารถส่งข้อมูล (IP packet) ไปยังคอมพิวเตอร์ปลายทางได้อย่างถูกต้อง Router จะรู้ว่าไปยัง IP ปลายทางได้ทาง Interface ใด หรือไปทาง Router ตัวไหน ได้จาก routing table นั่นเอง

ตัวอย่าง Routing Protocol ได้แก่ RIP (Routing Information Protocol) , OSPF (Open Shortest Path First), IGRP (Interior Gateway Routing Protocol) (Cisco Proprietary), EIGRP (Enhanced Interior Gateway Routing Protocol) (Cisco Proprietary) ,BGP (Border Gateway Protocol) เป็นต้น

Routing Protocol ทำงานอยู่บน Layer 3 ของ OSI 7 Layers ดังนั้นเมื่อเกิดปัญหาเกี่ยวกับ Network ก่อนตรวจสอบ Config Routing ให้ทำการตรวจสอบในส่วนของ Layer 1 และ Layer 2 ก่อนนะครับ
Routing Protocol แบ่งเป็น 2 กลุ่มใหญ่ๆคือ
1.กลุ่ม Static ( Static Route และ Default Route )
2.กลุ่ม Dynamic และ Dynamic ยังแบ่งเป็น 2 กลุ่มคือ IGP ( Routing ที่ใช้ภายในหน่วยงาน หรือภายในองค์กรตัวเอง ไม่ได้คุยต่าง ISP ) และ EGP (Routing ที่ใช้คุยข้ามองค์กร หรือหน่วยงาน หรือต่าง ISP กัน หรือใช้คุยระหว่าง ISP ) ตามรูปภาพ ควรเลือกใช้ Routing ให้เหมาะสมกับองค์กรของเรานะครับ

ตัวอย่างการ Confg Routing บน Router CISCO
1.Static Route
รูปแบบ Config คือ
Router(config)#ip route Network-IP Subnet-mask Gateway(IP Next hop หรือ Interface Router )

ตัวอย่าง config
Jodoi-Router(config)#ip route 172.31.10.0 255.255.255.0 10.10.10.2 (เมื่อต้องการส่งต่อ packet ไปยัง Network 172.31.10.0/24 ให้ส่ง packet ไปยัง IP 10.10.10.2 ซึ่งเป็น IP ของ Router ปลายทาง)
หรือ
Jodoi-Router(config)#ip route 172.31.10.0 255.255.255.0 Serial0/1 (เมื่อต้องการส่งต่อ packet ไปยัง Network 172.31.10.0/24 ให้ส่ง packet ออกทาง Interface Serial0/1 ของ Router ตัวเองนั่นเอง)

ตัวอย่างเพิ่มเติมสำหรับศิษย์โจดอยครับ Lab ในห้องเรียน
####### Static Route #######
B1(config)#ip route 111.111.111.0 255.255.255.0 22.22.22.22
B1(config)#ip route 222.222.222.0 255.255.255.0 22.22.22.22
B1(config)#ip route 33.33.33.32 255.255.255.252 22.22.22.22
B1(config)#ip route 44.44.44.32 255.255.255.248 22.22.22.22
B1(config)#ip route 55.55.55.40 255.255.255.248 22.22.22.22
B1(config)#ip route 66.66.66.48 255.255.255.248 22.22.22.22

HQ(config)#ip route 192.169.1.0 255.255.255.0 22.22.22.21
HQ(config)#ip route 44.44.44.32 255.255.255.248 33.33.33.34
HQ(config)#ip route 55.55.55.40 255.255.255.248 33.33.33.34
HQ(config)#ip route 66.66.66.48 255.255.255.248 33.33.33.34

ISP(config)#ip route 222.222.222.0 255.255.255.0 33.33.33.33
ISP(config)#ip route 111.111.111.0 255.255.255.0 33.33.33.33
ISP(config)#ip route 22.22.22.20 255.255.255.252 33.33.33.33
ISP(config)#ip route 192.169.1.0 255.255.255.0 33.33.33.33


download ทดสอบ Config

2.Default Route
รูปแบบ Config คือ
Router(config)#ip route 0.0.0.0 0.0.0.0 Gateway(IP Next hop หรือ Interface Router )

ตัวอย่าง config
Jodoi-Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.2 (เมื่อต้องการส่งต่อ packet ไปยัง Network ที่ไม่ได้อยู่ใน Routing Table ให้ส่ง packet ไปยัง IP 10.10.10.2 ซึ่งเป็น IP ของ Router ปลายทาง)
หรือ
Jodoi-Router(config)#ip route 0.0.0.0 0.0.0.0 Serial0/1 (เมื่อต้องการส่งต่อ packet ไปยัง Network ที่ไม่ได้อยู่ใน Routing Table ให้ส่ง packet ออกทาง Interface Serial0/1 ของ Router ตัวเองนั่นเอง)
หมายเหตุ : ในกรณีที่มี WAN เดียวต่อออก Internet จะหมายถึง ถ้าจะส่งต่อ packet ไปยัง IP ปลายทางทุก IP ให้ออกทาง Interface Serial0/1 ของ Router ตัวเองทั้งหมด

ตัวอย่างเพิ่มเติมสำหรับศิษย์โจดอยครับ Lab ในห้องเรียน
ดูรูปจากด้านบนได้นะครับ

########### Default Route #############
B1(config)#ip route 0.0.0.0 0.0.0.0 22.22.22.22

HQ(config)#ip route 0.0.0.0 0.0.0.0 33.33.33.34
HQ(config)#ip route 192.169.1.0 255.255.255.0 22.22.22.21

ISP(config)#ip route 0.0.0.0 0.0.0.0 33.33.33.33

( ดูตัวอย่างการ Config ได้บน youtube ครับ )

 

3.RIP (Routing Information Protocol)
รูปแบบ Config คือ
Router(config)# router rip
Router(config-router)# network ip-address(major-network)
Router(config-router)# version {1 | 2}
Router(config-router)# no auto-summary

ตัวอย่าง config
Jodoi-Router(config)# router rip
Jodoi-Router(config-router)# network 10.0.0.0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จักโดยประกาศเป็น major-network ตาม Class A Default /8 -->255.0.0.0 )
Jodoi-Router(config-router)# network 172.18.0.0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จักโดยประกาศเป็น major-network ตาม Class B Default /16 -->255.255.0.0 )
Jodoi-Router(config-router)# network 192.168.1.0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จักโดยประกาศเป็น major-network ตาม Class C Default /24 -->255.255.255.0 )
Jodoi-Router(config-router)# version 2 ( อนุญาต เฉพาะ RIP Version 2 packets เท่านั้น )
Jodoi-Router(config-router)# no auto-summary ( ทำการ Disables automatic summarization )

4.OSPF (Open Shortest Path First)
รูปแบบ Config คือ
Router(config)# router ospf process-id
Router(config-router)# network ip-address wildcard-mask area area-id

ตัวอย่าง config
Jodoi-Router(config)# router ospf 222 ( ใช้ process-id 222 สำหรับการทำ Routing OSPF )
Jodoi-Router(config-router)# network 192.168.129.16 0.0.0.3 area 0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จักโดยประกาศ Network 192.168.129.16/30 อยู่ใน Area = 0 )
Jodoi-Router(config-router)# network 10.10.10.0 0.0.0.255 area 0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จักโดยประกาศ Network 10.10.10.0/24 อยู่ใน Area = 0 )

ตัวอย่างเพิ่มเติมสำหรับศิษย์โจดอย lab ในห้องเรียนครับ
############ Config OSPF #######################
B1(config)#router ospf 100
B1(config-router)#network 192.169.1.0 0.0.0.255 area 0
B1(config-router)#network 22.22.22.20 0.0.0.3 area 0

HQ(config)#router ospf 100
HQ(config-router)#network 22.22.22.20 0.0.0.3 area 0
HQ(config-router)#network 111.111.111.0 0.0.0.255 area 0
HQ(config-router)#network 222.222.222.0 0.0.0.255 area 0
HQ(config-router)#network 33.33.33.32 0.0.0.3 area 0

ISP(config)#router ospf 100
ISP(config-router)#network 33.33.33.32 0.0.0.3 area 0
ISP(config-router)#network 44.44.44.32 0.0.0.7 area 0
ISP(config-router)#network 55.55.55.40 0.0.0.7 area 0
ISP(config-router)#network 66.66.66.48 0.0.0.7 area 0

( ดูตัวอย่างการ Config ได้บน youtube ครับ )

อีก 1 ตัวอย่าง Config บน GNS3 ครับ

การทำ Virtual-link ตามด้านล่างนะครับ

การหา DR&BDR ครับ

 

5.EIGRP (Enhanced Interior Gateway Routing Protocol) (Cisco Proprietary)
รูปแบบ Config คือ
Router(config)# router eigrp autonomous-system
Router(config-router)# network network-number
Router(config-router)# no auto-summary

ตัวอย่าง config
Jodoi-Router(config)# router eigrp 111 ( ใช้ค่า autonomous-system หมายเลย 111 Router ทุกตัวต้องใช้หมายเลขเดียวกัน )
Jodoi-Router(config-router)# network 10.0.0.0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จักโดยประกาศเป็น major-network ตาม Class A Default /8 -->255.0.0.0 )
Jodoi-Router(config-router)# network 172.18.0.0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จักโดยประกาศเป็น major-network ตาม Class B Default /16 -->255.255.0.0 )
Jodoi-Router(config-router)# network 192.168.1.0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จักโดยประกาศเป็น major-network ตาม Class C Default /24 -->255.255.255.0 )
Jodoi-Router(config-router)# no auto-summary ( ทำการ Disables automatic summarization )

ตัวอย่างเพิ่มเติมสำหรับศิษย์โจดอย lab ในห้องเรียนครับ
################ Config EIGRP ( CISCO ) ########################
B1(config)#router eigrp 222
B1(config-router)#no auto-summary
B1(config-router)#network 192.169.1.0
B1(config-router)#network 22.0.0.0

HQ(config)#router eigrp 222
HQ(config-router)#no auto-summary
HQ(config-router)#network 22.0.0.0
HQ(config-router)#network 111.0.0.0
HQ(config-router)#network 222.222.222.0
HQ(config-router)#network 33.0.0.0

ISP(config)#router eigrp 222
ISP(config-router)#no auto-summary
ISP(config-router)#network 33.0.0.0
ISP(config-router)#network 44.0.0.0
ISP(config-router)#network 55.0.0.0
ISP(config-router)#network 66.0.0.0

 ( ดูตัวอย่างการ Config ได้บน youtube ครับ )

การ Config บน GNS3 ครับ

 

6.BGP (Border Gateway Protocol)
รูปแบบ Config คือ
Router(config)# router bgp as-number
Router(config-router)# network network-number [mask network-mask] [route-map route-map-name]
Router(config-router)# neighbor {ip-address | peer-group-name} remote-as as-number

ตัวอย่าง config
Jodoi-Router(config)# router bgp 400 ( ใช้ค่า autonomous-system หมายเลย 400 Router ต้องใช้ autonomous-system หมายเลขของตัวเอง สามารถใช้หมายเลขแตกต่างกันได้ )
Jodoi-Router(config-router)# network 128.16.16.0 mask 255.255.255.0 ( ประกาศ Network ตัวเองให้ Router เพื่อนบ้านรู้จัก )
Jodoi-Router(config-router)# neighbor 10.10.10.1 remote-as 300 ( ประกาศว่า Router เพื่อนบ้านคือ IP อะไรและใช้ค่า autonomous-system หมายเลข 300 )

ดูวีดีโอตัวอย่าง Basic การ Config BGP ได้ตามวีดีโอด้านล่างนะครับ

 

ทั้งหมดนี้เป็นเพียง Basic Config Routing Protocol บน Router CISCO เท่านั้นนะครับ ยังไม่ได้รวมการปรับจูนและการตรวจสอบ เอาไว้จะ Update ในครั้งต่อไป

ต่อไปจะพูดถึงค่า AD ใน Routing Protocol แต่ละแบบ
ค่า AD หรือ Administrative Distance เป็นค่าประจำของ Routing Protocol แต่ละประเภทใช้ช่วยเลือกเส้นทางที่ดีที่สุด โดย router จะเลือกเส้นทางที่มีค่า AD ที่มีค่าน้อยที่สุดมาแสดงใน Routing Table นั่นเอง ตัวอย่างค่า Default AD ตามด้านล่าง

Network protocol AD
Connected route 0
Static 1
EIGRP Summary Route 5
External BGP 20
Internal EIGRP 90
IGRP 100
OSPF 110
IS-IS 115
RIP V1,V2 120
EGP 140
External EIGRP 170
Internal BGP 200

 

ยกตัวอย่างเช่น Router CISCO มีการ Config Routing Protocol ไว้หลายประเภท เช่น EIGRP , OSPF , RIP และ Router ได้รับค่า AD ค่า Default ตามด้านบนแล้ว Router จะเลือก EIGRP มาแสดงใน Routing Table เนื่องจากมีค่า AD น้อยสุดคือ 90 นั่นเอง และเรายังสามารถปรับแต่งค่า AD เพื่อใช้ในการทำระบบที่เป็น redundant ( Backup Link ) ได้อีกด้วยนะครับ

หวังว่าบทความนี้คงจะเป็นประโยชน์ไม่มากก็น้อยนะครับ ขอบคุณครับ

เรียบเรียงโดย อาจารย์เกรียงศักดิ์ นามโคตร ( อาจารย์ดอย ) Mr.Jodoi

More About us

"Jodoi The Best IT in Thailand" ศูนย์ฝึกอบรม Network และ IT เป็นบริษัทที่เป็นศูนย์อบรม และจัดจำหน่ายคอมพิวเตอร์ ระบบ Network และไอทีครบวงจร อันดับ 1 ของเมืองไทย

Jodoi Training Center

Facebook

นายเกรียงศักดิ์ นามโคตร (อาจารย์ดอย) ผู้ก่อตั้งบริษัท โจดอย ไอทีแอนด์เซอร์วิส จำกัด เจ้าของแบนด์โจดอย (JODOI) และเจ้าของสโลแกน " โจดอยทำได้ คุณก็ต้องทำได้ " รูัจัก อาจารย์ดอยมากขึ้น more

 
 

Contact Us

Mr. Kriangsak namkot
Mobile:081-9165773
E-mail:jodoi@jodoi.com